BungeeBlockVersion

A Bungee/Waterfall plugin that will block players from connecting with certain versions. It will not even allow the player to attempt to connect to a server inside your Bungee/Waterfall network.

You will need to use the protocol version numbers on the list instead of the normal version names. To find these names, you can go here.


Features

  • Block players if they are using a version that is on the list.
  • Custom disconnect message.
  • Custom “outdated server” message. It will show your supported versions. This feature is not finished.
  • Reload using /bbvreload. Uses permission node bbv.reload.

Config

# These versions will NOT be allowed to connect.
# These versions MUST be the version number. You can check the numbers here: https://wiki.vg/Protocol_version_numbers
# By default, all versions are listed here.
versions:
  - 47
  - 107
  - 108
  - 109
  - 110
  - 210
  - ...

# Send this message if someone connects with a blocked version.
# Use {VERSIONS} to show what versions your server uses. It will display like "1.8 to 1.16.3" or whatever.
# If you don't want to use {VERSIONS}, just remove it.
disconnect-message: "&cYou cannot connect with this version! We only allow version(s) {VERSIONS}."

# If someone is playing on a blocked version, then show them the correct versions. Replaces the outdated version message on the server list.
# This feature is not fully finished yet.
send-versions-if-outdated: false

# No touch please :)
config-version: 2

Download

It’s recommended to download the latest release. You can find releases at GitHub.

License

This plugin is released under GNU General Public License v3.